9 minutes ago · #1
Backfiring, stalling, no codes
I have a 2015 rzr 900 4 seater. I was up in the mountains when it started backfiring and losing power until it coasted to a stop and died. It didn’t want to start for a couple minutes and then it fired up and took off like nothing was wrong. I drove a couple miles and it did it again. Same thing over and over all the way back to camp. I thought maybe bad gas but have ran fresh gas through it since and had the dealership drain the tank. Replaced the air filter as it was in need as well. The dealership checked the fuel pump as well. It checked out fine. Anyway, I took it out again and it ran fine for 2 hours. Started trek back home and it started doing the same thing again. It only died on me once but it ran like it was underpowered when getting on it. And I could feel a slight surge of power when at full throttle. It acts like a plugged fuel filter when it starts doing it. The more gas I give it, the more it backfires and cuts out and eventually dies. Strong smell of gas when it does this. The mechanic at the dealership was scratching his head as it was showing no codes and everything I mentioned to him he said it should throw a code. The strange thing is after it sits for awhile, it fires right up and drives completely normal. It only happens after its been driven for quite awhile. I pulled the plugs tonight to check for fouling. They looked fine. I am going to replace them but I’m quite sure that isn’t the problem. I am at a lots and I don’t trust this machine at this point. Any ideas or help would be greatly appreciated.

Utah RZR Rentals

whence